Miro

Board loading issues on the mobile app
Resolved·Degraded performance

The board loading issue affecting the mobile apps has been fully resolved. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.

Mon, Apr 14, 2025, 02:39 PM
(1 week ago)
·
Affected components
Application
Updates

Resolved

The board loading issue affecting the mobile apps has been fully resolved. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.

Mon, Apr 14, 2025, 02:39 PM

Monitoring

We have implemented a fix. Our team will continue to monitor the systems closely to ensure stability. We will confirm the resolution shortly if no further issues are detected.

Mon, Apr 14, 2025, 02:30 PM

Identified

We identified the cause of issues loading boards on the mobile app . The issue is related to a recent service release. We are actively working on a fix to restore normal performance. We will provide further updates in 20 minutes

Mon, Apr 14, 2025, 02:10 PM(20 minutes earlier)
Powered by