Resolved
Incident was resolved. Thank you for your patience. Board functionality is back to normal.
Monitoring
We have implemented a fix for the boards not opening issue (Only boards with sticky stacks were affected). Functionality should be returning to normal. Our team will continue to monitor the systems closely to ensure stability. We will confirm the resolution shortly if no further issues are detected.
Identified
We are currently fixing an issue affecting board access in our platform. Some users may experience difficulties opening or accessing their boards. Our team is actively working on a resolution and we will provide updates as soon as we have more information. We apologize for any disruption this may cause.