Board loading issues.
Incident Report for Miro
Resolved
From 7:00 PM UTC to 7:42 PM UTC a small percentage of users encountered board loading issues. The issue has been fixed successfully within 42 minutes.

Please accept our apologies for any inconvenience this may have caused.
Posted 10 months ago. Oct 24, 2018 - 20:28 UTC
Monitoring
Our Technical Team implemented a fix for Board loading issues. Let us know if you still encounter any. We sincerely apologize for the inconveniences caused.
Posted 10 months ago. Oct 24, 2018 - 19:45 UTC
Investigating
A small percentage of users may have troubles while loading the Boards. We're currently investigating the issue! We apologize for the inconveniences caused.
Posted 10 months ago. Oct 24, 2018 - 19:14 UTC
This incident affected: Application.