Miro

Potential Service Disruptions (External Incident)
Resolved·Degraded performance

Earlier disruptions were due to a significant Amazon Web Services outage. While AWS is completing their remediation, the majority of their services are now operational and we have observed recovery in multiple third-party systems.

Mon, Oct 20, 2025, 11:01 AM
(1 day ago)
·
Affected components
Application
Billing
Log in ability
Mail System
Web Site
Updates

Resolved

Earlier disruptions were due to a significant Amazon Web Services outage. While AWS is completing their remediation, the majority of their services are now operational and we have observed recovery in multiple third-party systems.

Mon, Oct 20, 2025, 11:01 AM

Monitoring

We’re aware of widespread external issues that may be affecting some third-party integrations with Miro. While Miro itself is fully operational, certain features may experience temporary disruptions until these external issues are resolved.

Mon, Oct 20, 2025, 08:49 AM(2 hours earlier)
Powered by