Miro

Application loading issue
Resolved
Degraded performance

The Miro application’s performance degradation affecting the loading of boards on dashboards has been fully resolved. We apologize for any inconvenience this may have caused and appreciate your understanding.

If you continue to experience any issues, please reach out to our support team.

Wed, Feb 19, 2025, 04:52 PM
2d ago
Affected components
Application
Updates

Resolved

The Miro application’s performance degradation affecting the loading of boards on dashboards has been fully resolved. We apologize for any inconvenience this may have caused and appreciate your understanding.

If you continue to experience any issues, please reach out to our support team.

Wed, Feb 19, 2025, 04:52 PM
12m earlier...

Monitoring

We have implemented a fix, and the issue with loading boards from dashboards has been resolved successfully. Some users may still experience latency, but this is expected to return to normal soon. Our team will continue to monitor the systems closely to ensure stability. If no further issues are detected, we will confirm the resolution shortly.

Wed, Feb 19, 2025, 04:40 PM
21m earlier...

Identified

We identified the cause of the Miro application’s degraded performance. The issue is related to a configuration issue affecting system stability. We are actively working on a fix to restore normal performance. We will provide further updates in 30 minutes.

Wed, Feb 19, 2025, 04:18 PM
18m earlier...

Investigating

We are currently investigating reports of the Miro application's degraded performance. Users may experience slower response times or boards not loading when accessing the dashboard. Our engineering team is working to identify the root cause and will provide updates as we learn more. We apologize for any inconvenience this may cause and appreciate your patience.

Wed, Feb 19, 2025, 04:00 PM
Powered by