Miro

Partial disruption in email delivery
Resolved
Degraded performance

The disruption affecting email notifications delivery has been resolved. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.

Fri, Mar 21, 2025, 11:26 AM
5d ago
Affected components
Mail System
Updates

Resolved

The disruption affecting email notifications delivery has been resolved. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.

Fri, Mar 21, 2025, 11:26 AM
20h earlier...

Monitoring

Email notifications recovered from the disruption. Our team will continue to monitor the systems closely to ensure stability. We will confirm the resolution shortly if no further issues are detected.

Thu, Mar 20, 2025, 03:08 PM
7h earlier...

Identified

A limited group of customers might experience issues with receiving email notifications about mentions, sharing, daily and weekly updates. Critical emails such as password reset are not affected.

We keep monitoring the situation closely.

Thu, Mar 20, 2025, 07:56 AM
13h earlier...

Monitoring

A limited group of customers might experience issues with receiving email notifications about mentions, sharing, daily and weekly updates. Critical emails such as password reset are not affected. We are monitoring the situation closely.

Wed, Mar 19, 2025, 06:47 PM
Powered by