Miro

Ongoing incident with one of our providers - Cloudflare
Resolved·Degraded performance

Our services have returned to normal. We will continue to monitor the Cloudflare updates and change the status accordingly if needed.

Tue, Nov 18, 2025, 05:30 PM
(19 hours ago)
·
Affected components
Application
Updates

Resolved

Our services have returned to normal. We will continue to monitor the Cloudflare updates and change the status accordingly if needed.

Tue, Nov 18, 2025, 05:30 PM

Monitoring

Due to an ongoing incident with one of our providers - Cloudflare (see status here) Miro is experiencing degradation of certain features like Prototypes and Slides. We are monitoring the situation and will provide continuous updates.

Tue, Nov 18, 2025, 02:11 PM(3 hours earlier)
Powered by