From 13:41 to 13:51 UTC, a small percentage of users were having trouble loading the application. The issue has been resolved successfully within 10 minutes, and Miro is up and running again. Thank you for bearing with us!
Posted May 03, 2022 - 14:03 UTC
Monitoring
Some users were facing issues loading the application from 13:41 to 13:51 UTC. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted May 03, 2022 - 14:01 UTC
Identified
We have identified an issue where some users are unable to load the application. Our team is already investigating the problem and working on a fix that could get things back to normal.
Posted May 03, 2022 - 13:54 UTC
Investigating
Some users have encountered an issue loading the application and are unable to use our product at the moment. We are aware of the problem and urgently working on its investigation.