Some Miro users experiencing longer board loading times than usual
Incident Report for Miro
Resolved
The issue is now fully resolved, thank you for bearing with us!
Posted Sep 17, 2021 - 11:54 UTC
Monitoring
The fix was implemented and we are now monitoring the situation to ensure that everything works as expected for all Miro users.
Posted Sep 17, 2021 - 11:16 UTC
Investigating
Some Miro users may be experiencing longer board loading times than usual – the team is investigating the issue, and we will get back to you with an update when we know more.
Posted Sep 17, 2021 - 10:48 UTC
This incident affected: Application.