Board loading issue
Incident Report for Miro
Resolved
From 17:10 to 17:55 UTC, users were having trouble loading their boards. Our team implemented a fix, and Miro has been up and running since. Following an extended period of monitoring, we are resolving the incident at 20:57 UTC. Thank you for bearing with us!
Posted Jun 12, 2023 - 21:01 UTC
Monitoring
Some users were facing issues accessing their boards from 17:10 to 17:43 UTC. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Jun 12, 2023 - 17:55 UTC
Identified
We have identified an issue where some users are unable to load their boards. Our team is already investigating the problem and working on a fix that could get things back to normal.
Posted Jun 12, 2023 - 17:43 UTC
This incident affected: Application.