Board loading issue
Incident Report for Miro
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 11:00 UTC
Monitoring
Some users were facing issues accessing their boards from 6:20 UTC to 10:40 UTC. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Dec 15, 2023 - 10:53 UTC
This incident affected: Application.