Application loading issue
Incident Report for Miro
Resolved
The slow loading issue has been resolved successfully. Thank you for your patience.
Posted Oct 10, 2024 - 15:58 UTC
Update
Some users are facing issues with slow loading of the application. We have working on a fix for this issue.
Posted Oct 10, 2024 - 15:33 UTC
Identified
We have identified an issue where some users are unable to load the application. Our team is already investigating the problem and working on a fix to get things back to normal.
Posted Oct 10, 2024 - 15:02 UTC
This incident affected: Application.