Miro performance degradation
Incident Report for Miro
Postmortem

On March 17 from 14:20 to 15:38 UTC, Miro experienced intermittent performance degradation. Our Team took immediate action by increasing the capacity of the affected component. We will closely monitor and perform additional optimizations to mitigate a recurrence of a similar situation in the future.

Posted Mar 19, 2020 - 11:17 UTC

Resolved
From 14:20 to 15:38 UTC, Miro experienced intermittent performance degradation because of the increased number of active users. Our team successfully implemented a fix within 1 hour and 18 minutes. Since then, we haven't received any reports on this issue.

We apologize for the inconvenience caused and we appreciate your patience.
Posted Mar 17, 2020 - 18:32 UTC
Monitoring
Our Development Team implemented the fix for the issue and performance is back to normal.

If you still encounter the performance issues - please contact us via support@miro.com. Thank you.
Posted Mar 17, 2020 - 15:46 UTC
Identified
Miro experiences performance degradation due to a recent increase in the number of active users. Our team is investigating the issue and working on bringing Miro back online.
Posted Mar 17, 2020 - 15:07 UTC
This incident affected: Application.