Application loading issue
Incident Report for Miro
Resolved
From 9:39 to 10:49 UTC, a small percentage of users from Russia were having trouble loading the application. The issue has been resolved successfully within 70 minutes, and Miro is up and running again. Thank you for bearing with us!
Posted 3 months ago. May 24, 2019 - 11:24 UTC
Monitoring
Some users from Russia were facing issues loading the application. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.

If you're still encountering any issues, please get in touch with us via support@miro.com.
Posted 3 months ago. May 24, 2019 - 11:02 UTC
This incident affected: Log in ability and Application.