Integration with Google Drive temporarily unavailable
Incident Report for Miro
Postmortem

From 9:04 to 15:07 UTC on August 2, 2021 Miro customers were experiencing issues when trying to access Miro integration with Google Drive. Some users also reported temporarily loosing access to other integrations such as Jira Cards.

Out integrations team looked into this and found that the issue happened due to a recent change which led to temporary deletion of app keys. We also discovered that some customers may have experienced issues with accessing the integration with Google Drive starting from Friday, July 30.

At 13:23 UTC on August 2 we deployed a fix to restore the app keys, and Google Drive integration became available to all Miro users by 15:07 UTC. We also confirmed that all other integrations were working as expected.

Thanks for bearing with us and apologies from our team for the inconvenience caused!

Posted Aug 03, 2021 - 07:43 UTC

Resolved
The incident is now fully resolved, and all users can access Miro integration with Google Drive. Please, stay tuned for an incident recap, and thanks for bearing with us!
Posted Aug 02, 2021 - 15:02 UTC
Monitoring
We're now monitoring the situation as Google Drive integration is coming back to Miro users. Please, stay tuned for updates from our team, and apologies for any inconvenience this may have caused!
Posted Aug 02, 2021 - 13:55 UTC
Identified
The issue has been identified, and the team is rolling out a fix. We will let you know once the issue is fully resolved.
Posted Aug 02, 2021 - 09:46 UTC
Investigating
Some users may be experiencing issues with installing and accessing Miro integration with Google Drive. The team is investigating, and we will update you once we have more information.
Posted Aug 02, 2021 - 09:26 UTC