The website is temporarily unavailable for some users
Incident Report for Miro
Resolved
Miro website was temporarily unavailable from 09:52 to 10:26 UTC due to issues our third-party CDN provider was experiencing. The incident response team identified the root cause of the issue and deployed a fix at 10:25 UTC.

Now Miro website is working as expected. Thank you for your patience!
Posted Jun 08, 2021 - 10:46 UTC
Monitoring
The incident response team deployed a fix and Miro website is working as expected. We're on standby and monitoring the situation to ensure the issue is fully resolved.
Posted Jun 08, 2021 - 10:27 UTC
Identified
The incident response team identified the issue – please, stay tuned for updates, we will share them once we have more information.
Posted Jun 08, 2021 - 10:09 UTC
Investigating
Miro website (including login & sign-up) is temporarily unavailable for some Miro users. We're looking into the issue and will update the status page when we have more details.
Posted Jun 08, 2021 - 10:02 UTC
This incident affected: Web Site and Log in ability.