Users unable to open Miro boards via publicly shared links
Incident Report for Miro
Resolved
We have completed the roll out of a fix for an issue where users were unable to edit or view certain content on password protected Miro boards accessed via publicly shared links. Service has now been restored. Thank you for bearing with us.
Posted Jun 13, 2023 - 14:52 UTC
Monitoring
The fix for this issue is partially rolled out and we have been able to observe restoration of functionality for some impacted boards. We continue to monitor the roll out and will update when service is fully restored.
Posted Jun 13, 2023 - 13:51 UTC
Update
We are continuing to work on rolling out a fix for the issue where users are unable to edit or view certain content on password protected Miro boards accessed via publicly shared links. We thank you for your patience.
Posted Jun 13, 2023 - 12:00 UTC
Update
We have identified an issue where some users are unable to edit or view certain content on Miro boards accessed via publicly shared links. We continue to work on a fix for this issue.
Posted Jun 13, 2023 - 09:38 UTC
Identified
We have identified an issue where some users are unable to open Miro boards via publicly shared links. Our team is already investigating the problem and working on a fix that should get things back to normal.
Posted Jun 13, 2023 - 08:48 UTC
This incident affected: Application.