Application loading issue
Incident Report for Miro
Resolved
The fix applied was successful and service has been fully restored. We thank you again for your patience.
Posted Jan 29, 2024 - 08:42 UTC
Monitoring
A fix has been fully rolled out and service has been restored. Our team is continuing to monitor.
Posted Jan 29, 2024 - 08:28 UTC
Update
Some users continue to experience difficulties logging into Miro and loading boards. Our team is in the process of rolling out a fix and we expect service to be restored shortly.
Posted Jan 29, 2024 - 08:08 UTC
Identified
Some users are experiencing difficulties logging into Miro and loading boards. Our team has identified the issue and is actively working on resolving it. Thank you for your patience.
Posted Jan 29, 2024 - 07:14 UTC
This incident affected: Log in ability and Application.