Performance issues.
Incident Report for Miro
Postmortem

Root cause analysis:
The main reason for the incident was the degradation of one of the database servers, which led to a general degradation of the entire product and affected such processes as login, signup, opening the dashboard and loading the board. At the same time, users who had already been working on the boards could continue their work with a slight decrease in performance. Analysis of the cause showed that this degradation is caused by a rare case in which complicated queries were performed on the server. Unfortunately, we did not have a number of triggers that could have notified us about the problem in advance.

What has been done:
The database servers have been replaced with more productive ones. The configuration of the application servers is optimized to reduce the load on the database servers. We’ve also added monitoring of the necessary parameters for the timely detection of such problems. This case is added to the load test scripts. The system refactoring of the application to optimize operations for working with the database is still in progress.

Posted 11 months ago. Sep 28, 2018 - 09:02 UTC

Resolved
This incident has been resolved.
Posted 11 months ago. Sep 18, 2018 - 07:42 UTC
Monitoring
More fixes were rolled out. Some performance issues may appear while loading the Dashboard page. Our team is looking into the issue. We sincerely apologize for the inconveniences.
Posted 11 months ago. Sep 17, 2018 - 18:19 UTC
Identified
Our Development Team has implemented a fix. There still could be some small performance issues. Our Team will continue working on the issue.
Posted 11 months ago. Sep 17, 2018 - 15:54 UTC
Update
We are continuing to investigate the issue. The issue affects the loading of the Boards and file upload. Other components of the Board itself work properly.
Posted 11 months ago. Sep 17, 2018 - 15:20 UTC
Update
Our Development Team is working on the issue. We apologize for the inconveniences caused.
Posted 11 months ago. Sep 17, 2018 - 15:04 UTC
Investigating
A small percentage of users may experience performance issues while loading the Boards. Our Team is investigating the issue.
Posted 11 months ago. Sep 17, 2018 - 13:55 UTC
This incident affected: Application.