Board loading issue
Incident Report for Miro
Resolved
We can confirm that the issue with accessing boards has been fully resolved. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.
Posted Oct 23, 2024 - 12:38 UTC
Monitoring
Some users had trouble accessing their boards from 10:57 UTC to 11:27 UTC. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Oct 23, 2024 - 12:02 UTC
This incident affected: Application.