Board loading issue
Incident Report for Miro
Postmortem

On April 23d at 02:15 Miro lost one of the AWS instances with a proxy for connections to the database from the monitoring list. Our fault tolerance system worked correctly and Miro continued to work as usual. Unfortunately, a small percent of users had a board loading issue. As soon as the incident happened, we immediately started to solve the issue. At 05:15 these users could load their boards. At 09:49 all the consequences completely eliminated. After that, we held a retrospective meeting devoted to this incident and already repeated this issue on the test environment and planned to improve our application to work correctly in this situation

Posted 25 days ago. Apr 24, 2019 - 12:06 UTC

Resolved
From 2:15 UTC to 6:03 UTC, a small percentage of users were having trouble loading their boards. The issue has been resolved successfully within 3 hours and 48 minutes, and Miro is up and running again. Thank you for bearing with us!
Posted 26 days ago. Apr 23, 2019 - 13:56 UTC
Monitoring
Some users were facing issues accessing their boards from 2.15 to 6.03 UTC. We have implemented a fix for this issue and are currently monitoring the results. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted 26 days ago. Apr 23, 2019 - 06:03 UTC
Investigating
Some users have encountered an issue loading their boards and are unable to use our product at the moment. We are aware of the problem and urgently working on its investigation.
Posted 26 days ago. Apr 23, 2019 - 03:28 UTC
This incident affected: Web Site.