A segment of Miro users are experiencing issues loading Miro boards
Incident Report for Miro
Resolved
The incident is now fully resolved.
Posted May 23, 2022 - 11:15 UTC
Monitoring
A fix was rolled out and we're monitoring to ensure everything is working as expected. Thanks for bearing with us and apologies for the inconvenience!
Posted May 23, 2022 - 10:45 UTC
Identified
A segment of Miro users are experiencing issues loading Miro boards. Our team is aware and investigating. Please, stay tuned for updates
Posted May 23, 2022 - 10:26 UTC
This incident affected: Application.