Issues with loading the dashboard and boards
Incident Report for Miro
Postmortem

Miro dashboard and boards were unavailable from 06:44 to 08:19 UTC on July 29, 2021.

The event was detected by the incident response team at 06:46 UTC, and after conducting a thorough investigation they identified the issue that caused temporary service degradation and started fixing it.

The issue caused an increase in the latency of board and API requests to our database. This led to temporary performance degradation and made Miro dashboard and boards unavailable for users.

The fix was implemented at 07:51 UTC, and the affected users started regaining access to the dashboard and boards. The issue was fully resolved for all users by 08:19 UTC.

The incident response team already conducted the retrospective and identified the steps they will take to help identify such issues before they start negatively affecting the performance of our product in the future.

Posted Jul 29, 2021 - 13:15 UTC

Resolved
The incident has been fully resolved, and everything is working as expected now. We will be sharing the recap of today's issue here, and again want to apologise to all of the affected users for the inconvenience.
Posted Jul 29, 2021 - 08:51 UTC
Monitoring
The dashboard and boards are now loading, and we expect everything to work as expected. We are monitoring the situation, and will update the status page once the issues are fully resolved.
Posted Jul 29, 2021 - 08:20 UTC
Update
Some users may still be experiencing issues with accessing the dashboard and / or loading boards. We are working on fixing the issue for everyone. Apologies from the Miro team for the inconvenience!
Posted Jul 29, 2021 - 08:06 UTC
Identified
The incident team identified the root cause and implemented a fix.
Posted Jul 29, 2021 - 07:52 UTC
Update
The incident response team is continuing their investigation. We will update you when the fix is deployed and all systems are operational again.
Posted Jul 29, 2021 - 07:38 UTC
Update
We are continuing to investigate this issue.
Posted Jul 29, 2021 - 07:11 UTC
Investigating
Some Miro users are experiencing issues with loading the dashboard and boards. We are aware of this, and are investigating. Please, bear with us, and apologies for the inconvenience.
Posted Jul 29, 2021 - 06:52 UTC
This incident affected: Log in ability and Application.