Miro Boards Unavailable
Incident Report for Miro
Resolved
Between 14:19 UTC and 16:28 UTC, users experienced difficulties logging in and loading boards. The issue has been successfully resolved, and Miro is fully operational once again. Thank you for bearing with us!
Posted Nov 28, 2023 - 16:48 UTC
Monitoring
A fix has been implemented and we are monitoring service levels. Users may encounter some degraded performance when using Miro.
Posted Nov 28, 2023 - 16:28 UTC
Identified
We are currently experiencing a service degradation for core Miro board functionality. Engineering teams have identified the problem and are actively working on a fix.
Posted Nov 28, 2023 - 14:19 UTC
This incident affected: Log in ability and Application.