Application loading issues for users from Russia and Kazakshtan.
Incident Report for Miro
Resolved
From 2:30 PM to 2:40 UTC users from Russia and Kazakhstan were having issues loading Miro. The issue has been resolved successfully within 10 minutes. We apologize for the inconveniences caused.

If you're still encountering application loading issues, please get in touch with us via support@miro.com.
Posted 9 days ago. Sep 11, 2019 - 15:01 UTC
Monitoring
A fix was implemented and Miro is up for our users from Russia and Kazakhstan. We sincerely apologize for the inconveniences caused.

If you're still encountering application loading issues, please get in touch with us via support@miro.com.
Posted 9 days ago. Sep 11, 2019 - 14:44 UTC
Identified
Users from Russia and Kazakhstan can experience issues accessing Miro. Our team identified the issue and working on the fix.

We apologize for the inconvenience caused.
Posted 9 days ago. Sep 11, 2019 - 14:30 UTC
This incident affected: Web Site and Application.