Miro boards load slowly
Incident Report for Miro
Resolved
We have restored the majority of the content that has been partially missing from some of the customer boards as of October 09, 2020, 12:23 UTC. We encourage you to reach out to our support team via this form if you believe some of your content is still missing.
We're continuing to investigate the incident to ensure this doesn't happen again, and will follow-up here with a summary once we have more information.
Posted Oct 10, 2020 - 08:51 UTC
Update
Some users were facing issues loading the application from 3:40 to 5:00 UTC. We have implemented a fix and Miro is available now. Some users might have experienced partial content loss during the incident. We are currently in the process of identifying the boards and recovering the content. If your content has been affected, please report the issue and send the board link via this form. Please accept our sincere apologies for all the inconvenience this may have caused. Thank you for your patience.
Posted Oct 08, 2020 - 07:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 08, 2020 - 07:00 UTC
Monitoring
Some users were facing issues loading the application from 3:40 to 5:00 UTC. We have implemented a fix for this issue and are currently monitoring the results and identifying the boards which could be affected during the incident. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Oct 08, 2020 - 05:15 UTC
Investigating
Some users have encountered an issue loading their boards and are unable to use our product at the moment. We are aware of the problem and urgently working on its investigation.
Posted Oct 08, 2020 - 04:27 UTC
This incident affected: Application.